Prepar3Dv5 compatibility

All of our sceneries are compatible with P3Dv5, you can use the existing installer to install and select p3dv4 to install, when it comes to the page asking the directory, you can change it to the prepar3d v5 directory.
And then go to your p3dv5 menu scenery library to add the scenery.

Older Post Newer Post


Leave a comment

Please note, comments must be approved before they are published